PT-2014-8410
CVE-2014-8106
·
Published
2014-12-08
·
Updated
2024-06-15
Description by
CVSS 2.0
4.6
MediumMetricsAV:L/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
QEMU versions prior to 2.2.0
Description
The issue is related to a heap-based buffer overflow in the Cirrus VGA emulator. This allows local guest users to execute arbitrary code via vectors related to blit regions. The problem exists due to an incomplete fix for a previous issue.
Recommendations
For QEMU versions prior to 2.2.0, update to version 2.2.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the Cirrus VGA emulator until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾