PT-2014-8626

CVE-2014-8577

·

Published

2014-10-31

·

Updated

2017-09-08

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Croogo versions prior to 2.1.0
Description The issue allows remote attackers to inject arbitrary web script or HTML. This can be achieved via several parameters, including data[Contact][title] to the "admin/contacts/contacts/add" page, data[Block][title] or data[Block][alias] to the "admin/blocks/blocks/edit" page, data[Region][title] to the "admin/blocks/regions/add" page, data[Menu][title] or data[Menu][alias] to the "admin/menus/menus/add" page, or data[Link][title] to the "admin/menus/links/add/menu" page.
Recommendations For versions prior to 2.1.0, update to version 2.1.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the affected pages, such as "admin/contacts/contacts/add", "admin/blocks/blocks/edit", "admin/blocks/regions/add", "admin/menus/menus/add", and "admin/menus/links/add/menu", until a patch is applied. Avoid using the specified parameters in the affected API endpoints until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾