PT-2014-8735

CVE-2014-8799

·

Published

2014-11-13

·

Updated

2020-02-05

Description by

CVSS 2.0
5.0
Medium
MetricsAV:N/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions DukaPress plugin versions prior to 2.5.4
Description The issue allows remote attackers to read arbitrary files due to a directory traversal vulnerability in the dp img resize function. This is achieved by providing a .. (dot dot) in the src parameter to the "lib/dp image.php" endpoint.
Recommendations For versions prior to 2.5.4, update to version 2.5.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the lib/dp image.php endpoint to minimize the risk of exploitation. Avoid using the src parameter in the affected endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾