PT-2014-8760

CVE-2014-8958

·

Published

2014-11-25

·

Updated

2024-06-15

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions phpMyAdmin versions 4.0.x through 4.0.10.5 phpMyAdmin versions 4.1.x through 4.1.14.6 phpMyAdmin versions 4.2.x through 4.2.12
Description The issue allows remote authenticated users to inject arbitrary web script or HTML via various crafted inputs that are improperly handled during rendering of certain pages. This includes a crafted database, table, or column name during rendering of the table browse page, a crafted ENUM value during rendering of the table print view or zoom search page, or a crafted pma fontsize cookie during rendering of the home page.
Recommendations For phpMyAdmin versions 4.0.x through 4.0.10.5, update to version 4.0.10.6 or later. For phpMyAdmin versions 4.1.x through 4.1.14.6, update to version 4.1.14.7 or later. For phpMyAdmin versions 4.2.x through 4.2.12, update to a version later than 4.2.12.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2014-2385
DLA-336-1
DSA-3382-1
MGASA-2014-0495
OPENSUSE-SU-2024:10054-1
Found an issue in the description? Have something to add? Feel free to write us 👾