PT-2014-8866

CVE-2014-9175

·

Published

2014-12-02

·

Updated

2017-09-08

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions wpDataTables plugin version 1.5.3 and earlier
Description The issue allows remote attackers to execute arbitrary SQL commands. This is achieved via the table id parameter in a get wdtable action to the "/wp-admin/admin-ajax.php" API endpoint.
Recommendations For wpDataTables plugin version 1.5.3 and earlier, update to a version later than 1.5.3 to resolve the issue. As a temporary workaround, consider restricting access to the "/wp-admin/admin-ajax.php" API endpoint or avoiding the use of the table id parameter in the get wdtable action until a patch is available.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾