PT-2014-8981

CVE-2014-9390

·

Published

2014-12-19

·

Updated

2024-06-15

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Git versions 1.8.5.6 and earlier, 1.9.x through 1.9.4, 2.0.x through 2.0.4, 2.1.x through 2.1.3, and 2.2.x through 2.2.0 Mercurial versions prior to 3.2.3 Apple Xcode versions prior to 6.2 beta 3 mine versions prior to 08-12-2014 libgit2 versions up to 0.21.2 Egit versions prior to 08-12-2014 JGit versions prior to 08-12-2014
Description The issue allows remote Git servers to execute arbitrary commands via a tree containing a crafted .git/config file with (1) an ignorable Unicode codepoint, (2) a git~1/config representation, or (3) mixed case that is improperly handled on a case-insensitive filesystem.
Recommendations For Git versions 1.8.5.6 and earlier, 1.9.x through 1.9.4, 2.0.x through 2.0.4, 2.1.x through 2.1.3, and 2.2.x through 2.2.0, update to a version later than 1.8.5.6, 1.9.5, 2.0.5, 2.1.4, or 2.2.1 respectively. For Mercurial versions prior to 3.2.3, update to version 3.2.3 or later. For Apple Xcode versions prior to 6.2 beta 3, update to version 6.2 beta 3 or later. For mine versions prior to 08-12-2014, update to a version released after 08-12-2014. For libgit2 versions up to 0.21.2, update to a version later than 0.21.2. For Egit versions prior to 08-12-2014, update to a version released after 08-12-2014. For JGit versions prior to 08-12-2014, update to a version released after 08-12-2014.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-6VVC-C2M3-CJF3
ALT-PU-2015-1040
DLA-237-1
DSA-3257-1
MGASA-2014-0546
MGASA-2015-0325
OPENSUSE-SU-2024:10099-1
PYSEC-2020-217
SUSE-SU-2015_0100-1
SUSE-SU-2015_0154-2
USN-2470-1
Found an issue in the description? Have something to add? Feel free to write us 👾