PT-2015-1007
CVE-2015-0311
·
Published
2015-01-22
·
Updated
2025-11-17
Description by
CVSS 3.1
10
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Adobe Flash Player versions prior to 13.0.0.263
Adobe Flash Player versions 14.x through 16.x prior to 16.0.0.288
Adobe Flash Player version 11.2.202.438 and earlier on Linux
Description
The issue is related to a use-after-free vulnerability in the ByteArray::UncompressViaZlibVariant() function, allowing a remote attacker to execute arbitrary code or cause a denial of service via a specially crafted swf file. This vulnerability has been exploited in the wild, with reports of its use in January 2015.
Recommendations
For Adobe Flash Player versions prior to 13.0.0.263, update to version 13.0.0.263 or later.
For Adobe Flash Player versions 14.x through 16.x prior to 16.0.0.288, update to version 16.0.0.288 or later.
For Adobe Flash Player version 11.2.202.438 and earlier on Linux, update to a version later than 11.2.202.438.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾