PT-2015-1020
CVE-2015-2787
·
Published
2015-03-20
·
Updated
2018-10-30
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.4.39
PHP versions 5.5.x prior to 5.5.23
PHP versions 5.6.x prior to 5.6.7
Description
The issue is related to a use-after-free vulnerability in the
process nested data function. This vulnerability allows remote attackers to execute arbitrary code via a crafted unserialize call. The exploitation involves leveraging the use of the unset function within an wakeup function.Recommendations
For PHP versions prior to 5.4.39, update to version 5.4.39 or later.
For PHP versions 5.5.x prior to 5.5.23, update to version 5.5.23 or later.
For PHP versions 5.6.x prior to 5.6.7, update to version 5.6.7 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾