PT-2015-1797
CVE-2015-5754
·
Published
2015-08-13
·
Updated
2017-09-21
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Apple OS X versions prior to 10.10.5
Description
The issue is caused by a race condition in the Install Framework Legacy component, specifically in the runner in Install.framework. This condition can be exploited by a remote attacker using a specially crafted application that leverages incorrect privilege dropping associated with a locking error, allowing the execution of arbitrary code in a privileged context.
Recommendations
For Apple OS X versions prior to 10.10.5, update to version 10.10.5 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾