PT-2015-2445

CVE-2015-7698

·

Published

2015-10-21

·

Updated

2015-10-22

Description by

CVSS 2.0
9.0
High
MetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions icewind1991 SMB versions prior to 1.0.3
Description The issue exists due to the lack of neutralization of special elements used in operating system commands. This allows a remote attacker to execute arbitrary SMB commands using special metacharacters in user arguments. Specifically, the listShares function in Server.php and the connect or read functions in Share.php are vulnerable to shell metacharacters in the user argument.
Recommendations For versions prior to 1.0.3, update to version 1.0.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the listShares function in Server.php and the connect or read functions in Share.php to minimize the risk of exploitation. Avoid using metacharacters in the user argument in the affected API endpoints until the issue is resolved.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾