PT-2015-2876

CVE-2015-7219

·

Published

2015-12-15

·

Updated

2024-06-15

Description by

CVSS 2.0
5.0
Medium
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions Mozilla Firefox versions prior to 43.0
Description The issue is related to the HTTP/2 implementation, which allows remote attackers to cause a denial of service due to an integer underflow, assertion failure, and application exit. This can be triggered by a malformed PushPromise frame that causes decompressed-buffer length miscalculation and incorrect memory allocation.
Recommendations For versions prior to 43.0, update to version 43.0 or later to resolve the issue. As a temporary workaround, consider disabling HTTP/2 support until a patch is available. Restrict access to untrusted websites to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2015-2196
ALT-PU-2016-1454
MGASA-2016-0124
OPENSUSE-SU-2024:10071-1
USN-2833-1
Found an issue in the description? Have something to add? Feel free to write us 👾