PT-2015-2909

CVE-2015-8327

·

Published

2015-12-02

·

Updated

2024-06-15

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions cups-filters versions 1.0.42 through 1.2.0 Foomatic versions 4.0.x
Description The issue is related to an incomplete blacklist vulnerability in the util.c component of foomatic-rip, which is part of the cups-filters package and the Foomatic operating system. This vulnerability can be exploited by a remote attacker to execute arbitrary commands by using ` (backtick) characters in a print job.
Recommendations For cups-filters versions 1.0.42 through 1.2.0, update to version 1.2.0 or later to resolve the issue. For Foomatic versions 4.0.x, consider disabling the foomatic-rip component until a patch is available. As a temporary workaround, restrict the use of the ` (backtick) character in print jobs to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2016-1627
CESA-2016_0491
DLA-365-1
DSA-3411-1
DSA-3429-1
MGASA-2015-0465
OPENSUSE-SU-2024:10313-1
RHSA-2016:0491
RHSA-2016_0491
SUSE-SU-2016:0092-1
SUSE-SU-2016_0092-1
SUSE-SU-2016:0112-1
SUSE-SU-2016_0112-1
USN-2831-1
USN-2831-2
Found an issue in the description? Have something to add? Feel free to write us 👾