PT-2015-3158

CVE-2015-8662

·

Published

2015-12-24

·

Updated

2018-12-21

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions FFmpeg versions prior to 2.8.4
Description The issue arises from the ff dwt decode function in libavcodec/jpeg2000dwt.c not validating the number of decomposition levels before proceeding with Discrete Wavelet Transform decoding. This allows remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via crafted JPEG 2000 data.
Recommendations For versions prior to 2.8.4, update to version 2.8.4 or later to resolve the issue. As a temporary workaround, consider restricting the use of the ff dwt decode function until a patch is available. Avoid using crafted JPEG 2000 data that could exploit this issue.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
DLA-1611-1
MGASA-2016-0018
OPENSUSE-SU-2016_0089-1
OPENSUSE-SU-2024:10243-1
Found an issue in the description? Have something to add? Feel free to write us 👾