PT-2015-3159
CVE-2015-8663
·
Published
2015-12-24
·
Updated
2024-06-15
Description by
CVSS 3.1
8.3
HighMetricsAV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions
FFmpeg versions prior to 2.8.4
Description
The issue is related to the
ff get buffer function in libavcodec/utils.c, which preserves width and height values after a failure. This allows remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via a crafted .mov file.Recommendations
For versions prior to 2.8.4, update to version 2.8.4 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
ff get buffer function until a patch is available. Avoid using crafted .mov files that could exploit this issue until the update is applied. Found an issue in the description? Have something to add? Feel free to write us 👾