PT-2015-3239
CVE-2015-4644
·
Published
2015-06-18
·
Updated
2019-04-22
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.4.42
PHP versions 5.5.x prior to 5.5.26
PHP versions 5.6.x prior to 5.6.10
Description
The issue is related to the php pgsql meta data function in the PostgreSQL extension in PHP, which does not properly validate token extraction for table names. This could allow remote attackers to cause a denial of service, resulting in a NULL pointer dereference and application crash, via a crafted name.
Recommendations
For PHP versions prior to 5.4.42, update to version 5.4.42 or later.
For PHP versions 5.5.x prior to 5.5.26, update to version 5.5.26 or later.
For PHP versions 5.6.x prior to 5.6.10, update to version 5.6.10 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾