PT-2015-3277

CVE-2015-8896

·

Published

2015-12-31

·

Updated

2021-04-28

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions ImageMagick versions prior to 7.0.5-0
Description The issue is caused by an integer truncation problem in the coders/pict.c file, allowing remote attackers to cause a denial of service by crashing the application via a crafted .pict file. This can be exploited by using negative numbers when specifying the size of a field, potentially enabling an attacker to forge cross-site requests using a specially crafted pict file.
Recommendations For versions prior to 7.0.5-0, update to version 7.0.5-0 or later to resolve the issue. As a temporary workaround, consider restricting the use of .pict files or disabling the vulnerable coders/pict.c module until a patch is applied. Avoid using negative numbers when specifying field sizes in the affected module to minimize the risk of exploitation.
Exploitability
Fix
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2016-1580
CESA-2016_1237
DLA-353-1
OPENSUSE-SU-2016_1724-1
OPENSUSE-SU-2016_1748-1
OPENSUSE-SU-2016_1833-1
OPENSUSE-SU-2016_2073-1
RHSA-2016:1237
RHSA-2016_1237
SUSE-SU-2016:1782-1
SUSE-SU-2016:1783-1
SUSE-SU-2016:1784-1
USN-3131-1
Found an issue in the description? Have something to add? Feel free to write us 👾