PT-2015-3414
CVE-2015-1805
·
Published
2014-08-28
·
Updated
2025-09-29
Description by
CVSS 2.0
7.2
HighMetricsAV:L/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 3.16
Description
The issue is related to the pipe read and pipe write implementations in fs/pipe.c, which do not properly handle the side effects of failed copy to user inatomic and copy from user inatomic calls. This can allow local users to cause a denial of service, potentially leading to a system crash, or possibly gain privileges via a crafted application. The problem is described as an "I/O vector array overrun."
Recommendations
For Linux kernel versions prior to 3.16, update to version 3.16 or later to resolve the issue. As a temporary workaround, consider restricting access to the pipe read and pipe write functions to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾