PT-2015-3418
CVE-2015-3307
·
Published
2015-06-07
·
Updated
2019-04-22
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.4.40
PHP versions 5.5.x prior to 5.5.24
PHP versions 5.6.x prior to 5.6.8
Description
The issue is caused by a buffer overflow in the
phar parse metadata function. This can be exploited by a remote attacker to cause a denial of service or possibly have other unspecified impacts via a crafted tar archive.Recommendations
For PHP versions prior to 5.4.40, update to version 5.4.40 or later.
For PHP versions 5.5.x prior to 5.5.24, update to version 5.5.24 or later.
For PHP versions 5.6.x prior to 5.6.8, update to version 5.6.8 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾