PT-2015-3421
CVE-2015-2783
·
Published
2015-04-17
·
Updated
2019-04-22
Description by
CVSS 2.0
5.8
MediumMetricsAV:N/AC:M/Au:N/C:P/I:N/A:P
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.4.40
PHP versions 5.5.x prior to 5.5.24
PHP versions 5.6.x prior to 5.6.8
Description
The issue allows remote attackers to obtain sensitive information from process memory or cause a denial of service, resulting in a buffer over-read and application crash. This is related to the
phar parse metadata and phar parse pharfile functions when a crafted length value is used in conjunction with crafted serialized data in a phar archive. The vulnerability can also lead to privilege escalation or disclosure of protected information.Recommendations
For PHP versions prior to 5.4.40, update to version 5.4.40 or later.
For PHP versions 5.5.x prior to 5.5.24, update to version 5.5.24 or later.
For PHP versions 5.6.x prior to 5.6.8, update to version 5.6.8 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾