PT-2015-3432
CVE-2015-4147
·
Published
2015-06-09
·
Updated
2018-01-05
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.4.39
PHP versions 5.5.x prior to 5.5.23
PHP versions 5.6.x prior to 5.6.7
Description
The issue is related to a "type confusion" problem in the SoapClient:: call method, which does not properly verify the data type of default headers, allowing remote attackers to execute arbitrary code by providing crafted serialized data. This is a result of an error in data processing.
Recommendations
For PHP versions prior to 5.4.39, update to version 5.4.39 or later.
For PHP versions 5.5.x prior to 5.5.23, update to version 5.5.23 or later.
For PHP versions 5.6.x prior to 5.6.7, update to version 5.6.7 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾