PT-2015-3588
CVE-2013-7439
·
Published
2014-10-13
·
Updated
2016-10-18
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
libX11 versions prior to 1.6.0
Description
The issue is caused by multiple off-by-one errors in the
MakeBigReq and SetReqLen macros. These errors can trigger a buffer overflow when a crafted request is processed, potentially allowing remote attackers to have an unspecified impact.Recommendations
For libX11 versions prior to 1.6.0, update to version 1.6.0 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾