PT-2015-3628

CVE-2014-100021

·

Published

2015-01-13

·

Updated

2015-01-14

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions OrangeHRM versions prior to 3.1.2
Description A cross-site scripting (XSS) issue allows remote attackers to inject arbitrary web script or HTML via the empsearch[employee name][empId] parameter in the /pim/viewEmployeeList endpoint.
Recommendations For versions prior to 3.1.2, update to version 3.1.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the /pim/viewEmployeeList endpoint to minimize the risk of exploitation. Avoid using the empsearch[employee name][empId] parameter in the affected endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾