PT-2015-3646

CVE-2014-100038

·

Published

2015-01-13

·

Updated

2017-09-08

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Storytlr versions 1.3.dev and earlier
Description A cross-site scripting (XSS) issue allows remote attackers to inject arbitrary web script or HTML via the search parameter to the "search/" endpoint. This enables attackers to execute malicious scripts on the client-side.
Recommendations For versions 1.3.dev and earlier, update to a version later than 1.3.dev to resolve the issue. As a temporary workaround, consider restricting access to the "search/" endpoint or sanitizing the search parameter to prevent malicious input.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾