PT-2015-4175
CVE-2014-9277
·
Published
2014-12-03
·
Updated
2015-01-06
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
MediaWiki versions prior to 1.19.22
MediaWiki versions 1.20.x through 1.22.x before 1.22.14
MediaWiki versions 1.23.x before 1.23.7
Description
The issue allows remote attackers to conduct PHP object injection attacks via a crafted string containing
<cross-domain-policy> in a PHP format request. This occurs because the wfMangleFlashPolicy function in OutputHandler.php causes the string length to change when converting the request to <NOT-cross-domain-policy>.Recommendations
For MediaWiki versions prior to 1.19.22, update to version 1.19.22 or later.
For MediaWiki versions 1.20.x through 1.22.x before 1.22.14, update to version 1.22.14 or later.
For MediaWiki versions 1.23.x before 1.23.7, update to version 1.23.7 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾