PT-2015-4205

CVE-2014-9442

·

Published

2015-01-02

·

Updated

2015-01-05

Description by

CVSS 2.0
6.5
Medium
MetricsAV:N/AC:L/Au:S/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Cart66 Lite plugin versions prior to 1.5.4
Description The issue allows remote authenticated users to execute arbitrary SQL commands. This is achieved by exploiting the q parameter in a promotionProductSearch action to the "wp-admin/admin-ajax.php" endpoint.
Recommendations For versions prior to 1.5.4, update to version 1.5.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the "wp-admin/admin-ajax.php" endpoint or disabling the promotionProductSearch action until a patch is available. Avoid using the q parameter in the affected endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾