PT-2015-4313
CVE-2014-9625
·
Published
2015-01-20
·
Updated
2024-06-15
Description by
CVSS 2.0
6.8
MediumMetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
VideoLAN VLC media player versions prior to 2.1.6
Description
The issue is related to an integer truncation in the automated updater, specifically in the GetUpdateFile function, which allows remote attackers to conduct buffer overflow attacks. This can lead to the execution of arbitrary code or cause a denial of service, resulting in an application crash. The attack can be performed via a crafted file containing an overly long string argument.
Recommendations
For versions prior to 2.1.6, update to version 2.1.6 or later to resolve the issue.
As a temporary workaround, consider disabling the automated updater until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾