PT-2015-4526
CVE-2015-0219
·
Published
2015-01-13
·
Updated
2026-10-04
Description by
CVSS 4.0
6.9
MediumMetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
Django versions 1.4.17 and earlier
Django versions 1.6.x before 1.6.10
Django versions 1.7.x before 1.7.3
Description
The issue allows remote attackers to spoof WSGI headers by using an (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an
X-Auth User header.Recommendations
For Django versions 1.4.17 and earlier, update to version 1.4.18 or later.
For Django versions 1.6.x before 1.6.10, update to version 1.6.10 or later.
For Django versions 1.7.x before 1.7.3, update to version 1.7.3 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾