PT-2015-5389

CVE-2015-1613

·

Published

2015-02-16

·

Updated

2015-02-17

Description by

CVSS 2.0
4.0
Medium
MetricsAV:N/AC:L/Au:S/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions RhodeCode versions prior to 2.2.7
Description The issue allows remote authenticated users to obtain sensitive information, including API keys, by exploiting certain API methods. Specifically, the "update repo", "get locks", and "get user groups" API methods are vulnerable.
Recommendations For versions prior to 2.2.7, update to version 2.2.7 or later to resolve the issue. As a temporary workaround, consider restricting access to the vulnerable API methods until a patch is applied. Avoid using the vulnerable API endpoints, such as "update repo", "get locks", and "get user groups", in your applications until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
PYSEC-2015-33
Found an issue in the description? Have something to add? Feel free to write us 👾