PT-2015-5441

CVE-2015-1782

·

Published

2015-03-10

·

Updated

2024-06-15

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions libssh2 versions prior to 1.5.0
Description The issue allows remote servers to cause a denial of service (crash) or have other unspecified impact via crafted length values in an SSH MSG KEXINIT packet. This is related to the kex agree methods function in libssh2.
Recommendations For versions prior to 1.5.0, update to version 1.5.0 or later to resolve the issue. As a temporary workaround, consider restricting access to SSH services to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2015-2026
ALT-PU-2018-2261
CESA-2015_2140
DLA-171-1
DSA-3182-1
MGASA-2015-0107
OPENSUSE-SU-2024:10190-1
RHSA-2015:2140
RHSA-2015_2140
SUSE-RU-2023:4066-1
SUSE-SU-2015:0669-1
SUSE-SU-2015_0669-1
SUSE-SU-2015:0676-1
SUSE-SU-2015_0676-1
Found an issue in the description? Have something to add? Feel free to write us 👾