PT-2015-5651
CVE-2015-2189
·
Published
2015-03-06
·
Updated
2024-06-15
Description by
CVSS 2.0
5.0
MediumMetricsAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
Wireshark versions 1.10.x through 1.10.12
Wireshark versions 1.12.x through 1.12.3
Description
The issue is caused by an off-by-one error in the
pcapng read function in the pcapng file parser. This error allows remote attackers to cause a denial of service, resulting in an out-of-bounds read and application crash, by sending a crafted packet with an invalid Interface Statistics Block (ISB) interface ID.Recommendations
For Wireshark versions 1.10.x through 1.10.12, update to version 1.10.13 or later.
For Wireshark versions 1.12.x through 1.12.3, update to version 1.12.4 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾