PT-2015-5837
CVE-2015-2694
·
Published
2015-05-25
·
Updated
2024-06-15
Description by
CVSS 2.0
5.8
MediumMetricsAV:N/AC:M/Au:N/C:P/I:P/A:N
Name of the Vulnerable Software and Affected Versions
MIT Kerberos 5 versions 1.12.x through 1.13.1
Description
The issue allows remote attackers to bypass an intended preauthentication requirement. This can be achieved by providing either zero bytes of data or an arbitrary realm name. The problem is related to the kdcpreauth modules in MIT Kerberos 5, specifically in the plugins/preauth/otp/main.c and plugins/preauth/pkinit/pkinit srv.c files.
Recommendations
For versions 1.12.x through 1.13.1, update to version 1.13.2 or later to resolve the issue.
As a temporary workaround, consider restricting access to the kdcpreauth modules until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾