PT-2015-6040
CVE-2015-2996
·
Published
2015-06-08
·
Updated
2018-10-09
Description by
CVSS 2.0
8.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:N/A:C
Name of the Vulnerable Software and Affected Versions
SysAid Help Desk versions prior to 15.2
Description
The issue allows remote attackers to read arbitrary files or cause a denial of service due to directory traversal vulnerabilities. This can be achieved by using a .. (dot dot) in the
fileName parameter to either getGfiUpgradeFile or calculateRdsFileChecksum functions.Recommendations
For versions prior to 15.2, update to version 15.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the
getGfiUpgradeFile and calculateRdsFileChecksum functions to minimize the risk of exploitation. Avoid using the fileName parameter in the affected API endpoints until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾