PT-2015-6100

CVE-2015-3218

·

Published

2015-06-09

·

Updated

2018-07-18

Description by

CVSS 2.0
2.1
Low
MetricsAV:L/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions PolicyKit (aka polkit) versions prior to 0.113
Description The issue allows local users to cause a denial of service, resulting in a NULL pointer dereference and a crash of the polkitd daemon. This is achieved by calling the RegisterAuthenticationAgent function with an invalid object path, specifically through the authentication agent new function in polkitbackend/polkitbackendinteractiveauthority.c.
Recommendations For versions prior to 0.113, update to version 0.113 or later to resolve the issue.
Exploitability
Fix
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2015-1502
ALT-PU-2015-1588
MGASA-2015-0262
OPENSUSE-SU-2015_1734-1
OPENSUSE-SU-2024:10436-1
SUSE-SU-2015:1838-1
SUSE-SU-2015_1838-1
USN-3717-1
Found an issue in the description? Have something to add? Feel free to write us 👾