PT-2015-6101

CVE-2015-3219

·

Published

2015-08-20

·

Updated

2022-05-17

Description by

CVSS 4.0
5.3
Medium
MetricsAV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Name of the Vulnerable Software and Affected Versions OpenStack Dashboard (Horizon) versions 2014.2 through 2014.2.3 OpenStack Dashboard (Horizon) versions 2015.1.x before 2015.1.1
Description A cross-site scripting (XSS) issue exists due to improper handling of the description parameter in a heat template, which allows remote attackers to inject arbitrary web script or HTML. This occurs because the help text attribute in the Field class does not properly handle the input.
Recommendations For OpenStack Dashboard (Horizon) versions 2014.2 through 2014.2.3, update to version 2014.2.4 or later. For OpenStack Dashboard (Horizon) versions 2015.1.x before 2015.1.1, update to version 2015.1.1 or later. As a temporary workaround, consider restricting access to the heat template description parameter to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-RHJJ-F6GQ-6GX2
DSA-3617-1
PYSEC-2015-40
RHSA-2015:1679
SUSE-SU-2015:2064-1
Found an issue in the description? Have something to add? Feel free to write us 👾