PT-2015-6391
CVE-2015-4029
·
Published
2015-08-18
·
Updated
2019-05-30
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
pfSense versions prior to 2.2.3
Description
A cross-site scripting (XSS) issue exists in the WebGUI, allowing remote attackers to inject arbitrary web script or HTML via the
zone parameter in a del action to "services captiveportal zones.php" API endpoint.Recommendations
For versions prior to 2.2.3, update to version 2.2.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the "services captiveportal zones.php" endpoint to minimize the risk of exploitation. Avoid using the
zone parameter in the affected endpoint until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾