PT-2015-6433

CVE-2015-4152

·

Published

2015-06-15

·

Updated

2019-06-17

Description by

CVSS 2.0
6.4
Medium
MetricsAV:N/AC:L/Au:N/C:N/I:P/A:P
Name of the Vulnerable Software and Affected Versions Elasticsearch Logstash versions prior to 1.4.3
Description A directory traversal issue exists in the file output plugin, allowing remote attackers to write to arbitrary files through dynamic field references in the path option.
Recommendations For versions prior to 1.4.3, update to version 1.4.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the file output plugin to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾