PT-2015-6838

CVE-2015-5300

·

Published

2015-10-22

·

Updated

2024-06-15

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions NTP versions prior to 4.2.8p5
Description The issue allows remote attackers to bypass security restrictions by exploiting the failure to correctly implement the threshold limitation for the '-g' option. This can be achieved by responding to an unspecified number of requests from trusted sources, potentially allowing an attacker to set NTP to an arbitrary time or alter the time by up to 900 seconds, and leveraging a resulting denial of service. An attacker could exploit this using man-in-the-middle techniques to intercept NTP traffic and make multiple steps larger than the panic threshold.
Recommendations For NTP versions prior to 4.2.8p5, update to version 4.2.8p5 or later to resolve the issue. As a temporary workaround, consider restricting access to trusted sources to minimize the risk of exploitation. Avoid using the '-g' option until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2017-2335
CESA-2015_1930
DLA-335-1
DSA-3388-1
FREEBSD-SA-16_02
MGASA-2015-0413
OPENSUSE-SU-2016_1292-1
OPENSUSE-SU-2024:10181-1
RHSA-2015:1930
RHSA-2015_1930
SUSE-SU-2016:1175-1
SUSE-SU-2016_1175-1
SUSE-SU-2016:1177-1
SUSE-SU-2016_1177-1
SUSE-SU-2016:1247-1
SUSE-SU-2016_1247-1
SUSE-SU-2016:1311-1
USN-2783-1
Found an issue in the description? Have something to add? Feel free to write us 👾