PT-2015-6848

CVE-2015-5314

·

Published

2015-11-10

·

Updated

2024-06-15

Description by

CVSS 3.1
5.9
Medium
MetricsAV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions hostapd versions 2.0 through 2.5
Description The issue is related to the eap pwd process function in eap server/eap server pwd.c, which does not validate the size of the reassembly buffer for the final fragment in EAP-pwd messages. This can be exploited by remote attackers to cause a denial of service (process termination) by sending a large final fragment in an EAP-pwd message, particularly when used with an internal EAP server or a RADIUS server with EAP-pwd enabled.
Recommendations For hostapd versions 2.0 through 2.5, update to version 2.6 or later to resolve the issue.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2016-2482
DSA-3397-1
OPENSUSE-SU-2017_2896-1
OPENSUSE-SU-2024:10022-1
USN-2808-1
Found an issue in the description? Have something to add? Feel free to write us 👾