PT-2015-6853
CVE-2015-5320
·
Published
2015-11-25
·
Updated
2022-05-13
Description by
CVSS 4.0
6.9
MediumMetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
Jenkins versions prior to 1.638
Jenkins LTS versions prior to 1.625.2
Description
The issue arises from improper verification of the shared secret used in JNLP slave connections. This allows remote attackers to connect as slaves, potentially obtaining sensitive information or gaining administrative access if they have knowledge of a slave's name.
Recommendations
For Jenkins versions prior to 1.638, update to version 1.638 or later.
For Jenkins LTS versions prior to 1.625.2, update to version 1.625.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾