PT-2015-6976

CVE-2015-5531

·

Published

2015-08-17

·

Updated

2026-10-15

Description by

CVSS 2.0
5.0
Medium
MetricsAV:N/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions Elasticsearch versions prior to 1.6.1
Description The issue allows remote attackers to read arbitrary files via unspecified vectors related to snapshot API calls. This affects Elasticsearch, enabling attackers to access files they should not have access to.
Recommendations For versions prior to 1.6.1, update to version 1.6.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the snapshot API until a patch is applied. Avoid using the snapshot API for sensitive operations until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-JJQ8-VFJQ-J6V4
Found an issue in the description? Have something to add? Feel free to write us 👾