PT-2015-6977

CVE-2015-5534

·

Published

2015-11-02

·

Updated

2018-10-09

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Oxwall versions prior to 1.8
Description The issue allows remote attackers to hijack the authentication of administrators for requests. This can be achieved through multiple cross-site request forgery (CSRF) vulnerabilities. Specifically, attackers can put the website under maintenance via the maintenance enable parameter or conduct cross-site scripting (XSS) attacks via the maintenance text parameter to "admin/pages/maintenance".
Recommendations For versions prior to 1.8, update to version 1.8 or later to resolve the issue. As a temporary workaround, consider restricting access to the "admin/pages/maintenance" endpoint to minimize the risk of exploitation. Avoid using the maintenance enable and maintenance text parameters in this endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾