PT-2015-7617
CVE-2015-7799
·
Published
2015-10-06
·
Updated
2017-03-24
Description by
CVSS 2.0
4.9
MediumMetricsAV:L/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 4.2.3
Description
The issue is related to the slhc init function in the Linux kernel, which does not validate certain slot numbers. This allows local users to cause a denial of service, resulting in a NULL pointer dereference and system crash, by making a crafted PPPIOCSMAXCID ioctl call.
Recommendations
For Linux kernel versions prior to 4.2.3, update to version 4.2.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the PPPIOCSMAXCID ioctl call to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾