PT-2015-7854

Published

2015-11-17

·

Updated

2015-11-17

Description by

Score
N/A
Not available

No severity ratings or metrics are available. When they are, we'll update the corresponding info on the page.

Name of the Vulnerable Software and Affected Versions Ipsilon versions 0.1.0 through 1.0.0
Description The issue is related to the providers/saml2/admin.py file in the Identity Provider (IdP) server, where it does not properly check permissions to update the SAML2 Service Provider (SP) owner. This allows remote authenticated users to cause a denial of service via a duplicate SP name.
Recommendations For Ipsilon versions 0.1.0 through 1.0.0, update to version 1.0.1 or later to resolve the issue.
Vendors
Affected products
Related identifiers
PYSEC-2015-41
Found an issue in the description? Have something to add? Feel free to write us 👾