PT-2016-1127

CVE-2016-1904

·

Published

2016-01-19

·

Updated

2016-12-07

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions PHP versions prior to 7.0.2
Description The issue is caused by multiple integer overflows in the ext/standard/exec.c file of PHP, specifically in the php escape shell cmd and php escape shell arg functions. This can lead to a heap-based buffer overflow when a long string is provided to these functions, potentially allowing remote attackers to cause a denial of service or have other unspecified impacts.
Recommendations For PHP versions prior to 7.0.2, update to version 7.0.2 or later to resolve the issue. As a temporary workaround, consider restricting the input length to the php escape shell cmd and php escape shell arg functions to prevent exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾