PT-2016-1260

CVE-2016-1624

·

Published

2016-02-09

·

Updated

2024-06-15

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Google Chrome versions prior to 48.0.2564.109 Opera (affected versions not specified) Brotli (affected versions not specified)
Description The issue is caused by an integer underflow in the ProcessCommandsInternal function in dec/decode.c in Brotli. This can be exploited by remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via crafted data with brotli compression.
Recommendations For Google Chrome versions prior to 48.0.2564.109, update to version 48.0.2564.109 or later. For Opera, at the moment, there is no information about a newer version that contains a fix for this vulnerability. As a temporary workaround, consider disabling the ProcessCommandsInternal function in Brotli until a patch is available. Restrict access to the dec/decode.c module to minimize the risk of exploitation.
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2016-1098
DSA-3486-1
MGASA-2016-0127
OPENSUSE-SU-2024:10171-1
OPENSUSE-SU-2024:12948-1
RHSA-2016:0241
RHSA-2016_0241
USN-2895-1
Found an issue in the description? Have something to add? Feel free to write us 👾