PT-2016-1298
CVE-2015-5272
·
Published
2016-02-22
·
Updated
2020-12-01
Description by
CVSS 3.1
4.3
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Moodle versions 2.7.x through 2.7.9
Description
The issue is related to insufficient access control in the Forum module of the Moodle learning management system. This can be exploited by a remote attacker to modify data in arbitrary groups by elevating their role to a teacher. The vulnerability allows authenticated users to post to any group, potentially demonstrated by directly posting to "all participants".
Recommendations
For Moodle versions 2.7.x through 2.7.9, update to version 2.7.10 or later to resolve the issue. As a temporary workaround, consider restricting the teacher role to minimize the risk of exploitation. Avoid using the teacher role in the Forum module until the issue is resolved.
Found an issue in the description? Have something to add? Feel free to write us 👾