PT-2016-1308

CVE-2015-5342

·

Published

2015-12-05

·

Updated

2022-05-13

Description by

CVSS 3.1
4.3
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions Moodle versions 2.6.11 and earlier, 2.7.x through 2.7.10, 2.8.x through 2.8.8, 2.9.x through 2.9.2
Description The issue is related to insufficient access control in the choice module, allowing remote authenticated users to bypass intended access restrictions. This can be achieved by visiting a specific URL to add or delete responses in the closed state.
Recommendations For versions 2.6.11 and earlier, update to version 2.6.12 or later. For versions 2.7.x through 2.7.10, update to version 2.7.11 or later. For versions 2.8.x through 2.8.8, update to version 2.8.9 or later. For versions 2.9.x through 2.9.2, update to version 2.9.3 or later.
Exploitability
Fix
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
GHSA-6XPM-Q8X9-J3RW
MGASA-2015-0464
Found an issue in the description? Have something to add? Feel free to write us 👾