PT-2016-1412
CVE-2015-7581
·
Published
2016-01-31
·
Updated
2019-08-08
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Action Pack versions 4.x through 4.2.5.0
Action Pack versions 5.x through 5.0.0.beta1.0
Description
The issue is related to errors in resource management in the actionpack/lib/action dispatch/routing/route set.rb component of the Action Pack in Ruby on Rails. It allows a remote attacker to cause a denial of service by exploiting an application's use of a wildcard controller route, leading to superfluous caching and memory consumption.
Recommendations
For Action Pack versions 4.x through 4.2.5.0, update to version 4.2.5.1 or later.
For Action Pack versions 5.x through 5.0.0.beta1.0, update to version 5.0.0.beta1.1 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾