PT-2016-1519

CVE-2016-2856

·

Published

2016-03-13

·

Updated

2016-11-28

Description by

CVSS 3.1
8.4
High
MetricsAV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions glibc versions prior to 2.19-18+deb8u4 on Debian jessie glibc versions prior to 2.15-0ubuntu10.14 on Ubuntu 12.04 LTS glibc versions prior to 2.19-0ubuntu6.8 on Ubuntu 14.04 LTS glibc versions prior to 2.21-0ubuntu4.2 on Ubuntu 15.10 glibc versions prior to 2.23-0ubuntu1 on Ubuntu 16.04 LTS and 16.10
Description The issue is related to the pt chown function in the glibc package, which lacks a namespace check associated with file-descriptor passing. This allows local users to capture keystrokes and spoof data, and possibly gain privileges, via pts read and write operations. The problem is related to debian/sysdeps/linux.mk.
Recommendations For glibc versions prior to 2.19-18+deb8u4 on Debian jessie, update to version 2.19-18+deb8u4 or later. For glibc versions prior to 2.15-0ubuntu10.14 on Ubuntu 12.04 LTS, update to version 2.15-0ubuntu10.14 or later. For glibc versions prior to 2.19-0ubuntu6.8 on Ubuntu 14.04 LTS, update to version 2.19-0ubuntu6.8 or later. For glibc versions prior to 2.21-0ubuntu4.2 on Ubuntu 15.10, update to version 2.21-0ubuntu4.2 or later. For glibc versions prior to 2.23-0ubuntu1 on Ubuntu 16.04 LTS and 16.10, update to version 2.23-0ubuntu1 or later.
Exploitability
Exploit
Fix
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
USN-2985-1
USN-2985-2
Found an issue in the description? Have something to add? Feel free to write us 👾