PT-2016-1607
CVE-2016-3142
·
Published
2016-03-31
·
Updated
2018-01-05
Description by
CVSS 3.1
8.2
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.5.33
PHP versions 5.6.x prior to 5.6.19
Description
The issue is caused by a buffer overflow in the phar parse zipfile function of the PHAR extension in PHP. This can be exploited by a remote attacker to obtain sensitive information from process memory or cause a denial of service, resulting in an out-of-bounds read and application crash. The exploitation involves placing a PKx05x06 signature at an invalid location.
Recommendations
For PHP versions prior to 5.5.33, update to version 5.5.33 or later.
For PHP versions 5.6.x prior to 5.6.19, update to version 5.6.19 or later.
As a temporary workaround, consider restricting the use of the PHAR extension until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾